'Grouping or Joining' two songs together, Help?

Posted by: Svend

'Grouping or Joining' two songs together, Help? - 11/18/08 06:57 PM

I've tried selecting Get Info and making these songs part of a compilation. I've also checked the box in Preferences to group compilations when browsing. It just doesn't seem to work







The only way I can get these two songs (The Load Out and Stay) to play one after another is to sort by artist and then they one after another. For example if I sort by Song title, then whatever comes after The Load Out is played instead of Stay.




I bought these from ITMS, if that makes any difference.

What am I missing?
Posted by: padmavyuha

Re: 'Grouping or Joining' two songs together, Help? - 11/19/08 12:33 AM

I don't think you're missing anything, I think iTunes is grouping them as a compilation, it's just not displaying the compilation in the track order you want.

Two options come to mind - the first is to ctrl/right-click on the column headers and add Track No., then sort the compilation by track number - that gets messy if you have more than one album in the playlist though. The other more permanent solution is to edit the track titles in such a away that they sort alphabetically in the order you want them to play, e.g. by adding track nos. to the track titles.

It's basically a shortcoming if iTunes that you can't define any sort of permanent hierarchical sort order, such as by Artist->Album->Track no. It does something sort of like this instead - if you click on the Album column header, it cycles between Artist, Album by Artist, Album by Year. Album by Artist is the most useful - sorts the tracks by Artist->Artist's Albums->Track Nos., but the artist order is sometimes unexpected...

- padmavyuha
Posted by: Nagromme

Re: 'Grouping or Joining' two songs together, Help? - 11/19/08 01:17 PM

Actually my iTunes DOES sort by Artist > Album > track #. In fact, no matter which of the Album sorts I use, tracks are always in order by #. This works for 2-disc compilation sets as well: disc one is listed with all tracks in order, followed by disc two.

So just sort by Album and you should be fine.

if not, then maybe something else is wrong with just that particular album? Are track numbers messed up? (That can be fixes in Get Info.)

Note that in Get Info > Sorting you can define a "hidden" song name, album name, artist name, etc. that is used JUST for sorting, and not displayed. That could give you a workaround if you can't find the cause of the problem.

(Also note that in Get Info > Options there's a Gapless Album checkbox if you need songs to blend smoothly into one without gap or overlap.)