Jailbreak your iPhone? Better wait to install 4.2

Posted by: John Rougeux

Jailbreak your iPhone? Better wait to install 4.2 - 11/24/10 09:52 AM

iPhone unlockers be warned: Apple has implemented baseband signature check in iOS 4.2.1

Quote:
Apple has once again raised the stakes in their continuing cat and mouse game with unlockers by implementing a boot level signature check in iOS 4.2.1 that will cause the device to fail to boot if the baseband firmware is not correct. This is clearly a reaction to TinyUmbrella’s ability to block baseband upgrades on the iPhone 4.
If you try and implement TinyUmbrella when installing 4.2.1 you will be thrown into recovery mode without the ability to kick yourself out of it unless you install the new baseband or downgrade back to iOS 4.1 (if you’ve saved your SHSH blobs).
If you plan on unlocking your iPhone it is recommended that you hold off on installing 4.2.1 as there is no current method available to maintain an unlockable baseband. Once the unlocking tools or custom firmware utilities have been updated and released it will be safe to upgrade.


While jailbreaking may be legal now, Apple's not going to let you do it easily! heh
Posted by: padmavyuha

Re: Jailbreak your iPhone? Better wait to install 4.2 - 11/27/10 10:56 AM

Works fine on a 3G though smile
Posted by: NucleusG4

Re: Jailbreak your iPhone? Better wait to install 4.2 - 11/28/10 07:21 AM

3G??


OMG.. that is sooo last year....
whistle
Posted by: SgtBaxter

Re: Jailbreak your iPhone? Better wait to install 4.2 - 11/28/10 04:39 PM

Hmmm, that's an interesting tactic.

People bitched and moaned about the Droid X bootloader and that the "efuse" was going to make it impossible to install custom ROMs, yet here I am running Rubix. The thing wasn't even out a week and everything was bypassed, yet Motorola admitted the eFuse was never about blocking that kind of stuff anyway.
Posted by: padmavyuha

Re: Jailbreak your iPhone? Better wait to install 4.2 - 11/30/10 01:39 AM

Originally Posted By: NucleusG4
3G??


OMG.. that is sooo last year....
whistle

Yeah, and being able to run iOS 4.2.1 jailbroken is so last year, too I suppose grin