booting problems with g3 iMac blue berry

Posted by: capdiamont

booting problems with g3 iMac blue berry - 12/30/07 11:45 PM

I got my hands on a working blue berry iMac for $50. 6gn hd, 256 ram. USB 1.1 only. I want this for a file server. I got os 8.5 with it, 9.2.2 installed. I bought 10.1.3. Hd's are ones I had laying around, pata.

I tried upgrading the harddrive. I tried a 160gb one, able to boot, the os x cd, and partition it, only 128gb can be seen, but can't partition it so it will install on it.

80gb will not allow the system to boot. It was he boot drive for winxp sp2.

15gb, was able to partition it, and install os x on it, unable to boot off harddrive. I tried installing 8.5, same thing.

the origional hd, untouched, and still working on 9.2.2.

I don't understand why the 15gb won't boot.

Looks like the HD connector on the logic board is a mini ata, so I'll need a 2.5" to 3.5" ata adaptor to use a regular pc slave/master.

The cd connector on the logic board is a regular 3.5" ata, but looks like a 2.5" ata at the cd-rom. Can I still add a slave HD and keep the cd-rom? Or is it best to ditch it, after installing the os?
Posted by: Speedmike

Re: booting problems with g3 iMac blue berry - 12/31/07 05:55 AM

If the hard disk is larger than 8 GB, then you need to partition the HDD into at least 2 parts, You then have to select a destination partition for Mac OS X that is completely within the first 8 GB of the disk.

I used to have a Strawberry 333 MHZ iMac and I believe that the HDD is a standard IDE one. The biggest hard drive you can put in and have running without third party assistance is 128gb.

I hope that helped? Maybe you already knew that? I don't have my iMac anymore so I can't really help you with the rest of your question.
Posted by: capdiamont

Re: booting problems with g3 iMac blue berry - 12/31/07 06:40 AM

the 1st partition was 6gb, which is the only way os x would allow me to select it, to install on it. but no boot.
Posted by: 987687

Re: booting problems with g3 iMac blue berry - 12/31/07 07:26 AM

If you have the latest firmware the 8GB limit does not exist. I installed 10.4 to a 20GB hdd in a firewire enclosure then transplanted it into my first generation clamshell which boots 10.4 fine and uses all 18.7GB of the hard drive. (A 20GB drive only has 18.7GB) To install the firmware you must have macos9 installed on the hard drive, it will not work from a CD. I think I actually updated mine booted from a USB flash drive, but that's not supposed to work, so your millage may vary.
Posted by: capdiamont

Re: booting problems with g3 iMac blue berry - 12/31/07 07:58 PM

I thought you needed fire wire to install 10.4+. Why won't it boot?
Posted by: 987687

Re: booting problems with g3 iMac blue berry - 12/31/07 10:00 PM

I think 10.4 install DVD won't boot on a computer that does not have firewire, but it will run on one. You might have to repair permissions, after I installed to the FW drive all the permissions were messed up, and repairing permissions made it work.
Posted by: Waragainstsleep

Re: booting problems with g3 iMac blue berry - 01/01/08 04:03 AM

You can use XPostFacto to install Tiger on the slot load iMacs.
Posted by: capdiamont

Re: booting problems with g3 iMac blue berry - 01/01/08 06:10 AM

What did I miss when installing either 8.5 or 10.1.3 to make my iMac bootable?

Wish I'd known about tiger, I'd use my wife's old disk.
Posted by: Waragainstsleep

Re: booting problems with g3 iMac blue berry - 01/01/08 10:53 AM

Have you checked the jumper settings?
Posted by: capdiamont

Re: booting problems with g3 iMac blue berry - 01/01/08 01:15 PM

Jumper is set to master, on all drives tried.