PowerBook G4 Logic Board Replacement Question

Posted by: JaysAtomic

PowerBook G4 Logic Board Replacement Question - 08/26/08 04:15 PM

I have a PowerBook G4 DVI 867MHz. I need to replace the logic board (big surprise). I found a 1GHz logic board from another PowerBook G4 DVI model. My question is, is this a direct swap? Or am I forced to track down another 867MHz logic board? Anyone...?

Thanks in advance!!
Posted by: Waragainstsleep

Re: PowerBook G4 Logic Board Replacement Question - 08/27/08 01:20 AM

The board will fit, the display will attach fine, as will the drives, RAM, airport card, inverter and modem. The only other bit you might need would be the battery charge board. (The daughter board at the front which joins the logic and battery). But you may not even need that. Actually some models had slightly different keyboards too, though it was really only the keys which were different.
Posted by: JaysAtomic

Re: PowerBook G4 Logic Board Replacement Question - 08/28/08 09:39 PM

Thanks for the input. Yeah, I found some info poking around on the web... Looks like the 867 and the 1GHz are considered in the same "family". It appears the next step up, or the previous step down (800MHz) will not work... not that I would consider downgrading, hehe. Bonus with the 1GHz board is 64MB video vs. the 32 of the 867 board. So I am happy it looks like I can upgrade for a reasonable price. Cant wait to get this thing back together! I think ill throw a new HDD in there while I have it open... still has the 4600 rpm stock drive in there.

Thanks again!
Posted by: JaysAtomic

Re: PowerBook G4 Logic Board Replacement Question - 09/02/08 05:19 PM

Well, before ordering a new logic board I decided to give it one last ditch effort to fix my existing one. I had the vertical lines and scrambled video issue with the powerbook. I also had a square moving around the screen as I moved the mouse which seems to be common with people experiencing this problem. Thats what led me to believe everything was functioning as it should except for the video of course.

I removed the keyboard and powered up the unit, allowing it to run for about 15 mins or so to let the fans kick on. Then, once I achieved the warmest temp it was going to reach on its own, I used an embossing heat gun (has a smaller exhaust port than a traditional heat gun, so I could control where the heat was going more easily rather than heating half the board) which came from and arts and crafts store. It said on the package that it was capable of 650 degrees F. I fired it up and with a back and forth motion applied heat evenly to the heat sink of the video chip. Within about a minute the fans kicked into high gear and shortly after the computer went into thermal protection and went to sleep on its own.

At this point I decided to let the machine rest to come back to room temperature on its own. After the wait I fired it up and the video issue is fixed and has been working all day problem free! I am more than thrilled. Hopefully it holds up. Looks promising so far. If it fails down the road, so be it. Up until today I considered that logic board trash anyway. So I cant complain later if it doesnt hold.

A few tips if anyone is willing to use this method to try to revive a forgotten PowerBook... I removed the battery while performing this for safety reasons involving heat, batteries and in the event of a short of some kind. This was probably overkill, but it cant hurt. Also, the heat sink your working with is the rectangular one all the way to the top left of the board. This has a wire passing directly through it which plugs in to the modem I believe, directly to its left. Unplug this wire, remove it from the heat sink channel, and move it out of the way. No need to heat the wire to 650 degrees for no reason smile I applied the heat in a back and forth motion to try to evenly transfer heat through the heat sink, not sure if this mattered but I figured this would prevent a "hot spot" of transfer. Once the computer sleeps on its own, remove the power cord (you should already have removed the battery too). You will probably notice the sleep light is still on (yes, even without the battery or power cord). Use the PMU reset button that resides on the top right of the logic board. Hold it down for about 5 seconds and when you let go the light should be off. Now, Be Patient! Im sure you are dying to see if it worked, but I believe its important for the unit to return to a normal temperature before powering it back up. I waited till the heat sinks were room temp again.

If there is any interest, I can take a few pics to better illustrate the areas I refer to above. Its funny, I found tons of info on the web regarding the iBook video issues that were resolved in a similar manner, but none on the PowerBook that I could find. I did find countless threads on people with the same problem I was experiencing though, and everyone always told them to get a new logic board. I think this is worth a shot as its free and nothing has to come apart on the unit other than removing the keyboard.

Please keep in mind that this may not work for everyone, it could do more damage possibly since we are talking about using extreme heat. Also, you need to be able to know you are dealing with a video problem and not another issue caused elsewhere in the hardware.

I have seen countless posts around the web that say "Does the iBook fix work on the PowerBook?", but never an answer. Well, here is one vote for Yes it does!

Mine is a PowerBook G4 867MHz DVI just for reference.
Posted by: oojacoboo

Re: PowerBook G4 Logic Board Replacement Question - 09/02/08 08:48 PM

Jay, great write up!! Glad to hear that you were able to solve that issue. Please be sure to let us know how that holds up wink
Posted by: bmswalla

Re: PowerBook G4 Logic Board Replacement Question - 09/28/08 01:53 PM

Jay,

I am thrilled to find your post as I have the same problem with a 800 MHz DVI powerbook; the video is scrambled and the mouse is a confused blocky pattern. As you found, it appears to be only a video issue - if I log in via VNC or screen sharing the video still comes up scrambled.

Can you post an update? Did your fix hold? Also, I would appreciate if you could post some pictures showing the repair process in more detail!

Thanks for the great discovery,
Brian