Huh?

Posted by: steveg

Huh? - 12/14/12 04:32 AM



Click to enlarge...

I'm seeing this ONLY in Safari on my Mini — and on my MBP, but not under the icons. Not in Firefox Aurora or Google Chrome. I've check and confirmed language settings in system and Safari prefs, and iCloud settings. Have repaired permissions, restarted, cleared caches and history... No joy.

Any ideas?

Also, I've just enable PhotoStream on both Macs and my iPhone, so shouldn't I see that icon on the iCloud home page as well?
Posted by: steveg

Re: Huh? - 12/14/12 04:53 AM

Never mind that second question (PhotoStream icon). Found the answer.
Posted by: Acumowchek

Re: Huh? - 12/14/12 06:15 AM

Font conflict?
I've had a bad font do some wacky stuff with the system.
Posted by: steveg

Re: Huh? - 12/14/12 06:21 AM

Nope. All fonts are good and no conflicts.
Posted by: six_of_one

Re: Huh? - 12/14/12 06:34 AM

Is this a new issue? Have you perhaps recently installed any software that may have also installed its own fonts?

I'm gonna guess you may have multiple versions of whatever font the app/system wants to use -- not *conflicting* fonts, mind you, just different versions =)
Posted by: Jim_

Re: Huh? - 12/14/12 07:08 AM

Hmm.
Posted by: steveg

Re: Huh? - 12/14/12 07:55 AM

Hmm indeed. File this one under "Go figure". That solved it. Now on to the MBP.

Guess I should've checked the Apple support pages first. But then, you'd be out of a job! grin

Reminds me of the time (back in the early 90's) I was having problems with my Amiga (no snickering, please). When I got to the service center with the machine, the problem was gone. The tech said, "Sometimes they just wanna go for a ride." laugh
Posted by: Acumowchek

Re: Huh? - 12/14/12 09:09 AM

There's just too many darned Helveticas out there…
Posted by: steveg

Re: Huh? - 12/16/12 04:46 AM

Unbelievable. It reverted again! WTF??? mad
Posted by: Jim_

Re: Huh? - 12/16/12 06:17 AM

If the Safe Boot is what fixed it, you have some sort of font conflict. Safe Boot clears font caches.
Posted by: steveg

Re: Huh? - 12/16/12 06:42 AM

I'll run Font Doctor again and re-inspect my active fonts in Suitcase. But it's odd that this occurs only in Safari and only in my iCloud front page.
Posted by: steveg

Re: Huh? - 12/16/12 07:40 AM

Ran FD again. It found a couple of duplicates (none of which would be associated with a website), which I moved. Plus I emptied the font caches. Did this on both machines. The MBP only displays the garbled text in the log-out link at the top right, but the text below the icons is ok. On the Mini, all text except my name is garbled.

Safe mode clears it out, but another restart screws up the text all over again. So I'm convinced this has more to do with Safari than anything else.
Posted by: Jim_

Re: Huh? - 12/16/12 09:42 AM

Originally Posted By: steveg
I'll run Font Doctor again and re-inspect my active fonts in Suitcase. But it's odd that this occurs only in Safari and only in my iCloud front page.
Well you're odd too, but it's a Helvetica font conflict dood, I'm tellin' ya'.

Safe Boot not only clears font caches but it also turns off all non-Apple fonts, and stops third party stuff from loading, like Suitcase Fusion Core.

Set Suitcase to not start at startup, also see what fonts are located in Users/you/Library/Fonts and Library/Fonts. If there are any move them out, move them to folders so you can put them back if needed. Do a Safe Boot to clear caches. Reboot back to regular. See if the problem is still there. If so check in System/Library/Fonts and see if you have any non-Apple fonts in there. Make note of any Helveticas.

Download this, it will tell you what should be in System/Library/Fonts.

Here's a good linktoo. http://www.jklstudios.com/misc/osxfonts.html It explains how to remove protected fonts, ones the great Apple deems necessary and replace them with your own versions

Do a search on that page for 'Removing Helvetica, Helvetica Neue and Helvetica Light', it will take you to the directions for removing the Helveticas permanently. It says Leopards, but the next section covers Lions.

BTW it may not be a conflict between Helveticas, it may be a Helvetica that you activate that is corrupt in some way. I know, you ran FontDoctor, but I've found that FD is not 100% reliable, and I have found it to break fonts that it says it fixed.

It may also be a Font ID number conflict. The system is trying to use Helvetica #123456 (ex.) but that is pointing to something else.

Peggy
Posted by: steveg

Re: Huh? - 12/16/12 10:44 AM

There's a lot of chatter a/b Helvetica in most of the threads I've been reading. I don't have Suitcase as a log-in item (Fusion 4 doesn't need to be running in the background the way older versions did). But I did see several mentions of clicking the "Stop Type Core" button in Suitcase preferences.

Since I have very limited need of any of the Helveticas in my work fonts folder, I'm going to start by deleting those sets and see what happens after another safe boot sequence. Only if that doesn't help will I try messing around with the steps outlined in those two guides. But having once experienced how font problems can bring a system down, I'll take those steps only as a last resort.

Wish me luck...
Posted by: Jim_

Re: Huh? - 12/16/12 10:50 AM

Right, it's the Core that runs at startup, not the app itself.

Good Luck.
Posted by: steveg

Re: Huh? - 12/16/12 11:17 AM

Who'd a thunk it? Seems to have worked. I didn't disable the Type Core, but I deleted all non-system Helvetica sets from Suitcase. Did the safe boot, which as we've already seen, works in the short term. The litmus test was to do a regular restart next, because that's when the problem returned. In fact, before restarting I opened up a few InDesign files to make sure all my needed fonts were loading — including a file that needed Helvetica Nue — and everything was ok. After the restart, the iCloud page text was as it should be in Safari (same as in Aurora and Chrome). Hopefully, I'll have the same result with the MBP.

Thanks for the guidance.
Posted by: steveg

Re: Huh? - 12/16/12 12:03 PM

Seems ok for now on the MBP. Will see if it sticks.
Posted by: Jim_

Re: Huh? - 12/16/12 12:50 PM

Helvetica and HelveticaNue are both system fonts.
Posted by: Jim_

Re: Huh? - 12/16/12 12:55 PM

BTW. Whadda ya mean who'd a thunk? I told you what the problem was.

You doubt me? mad

grin
Posted by: steveg

Re: Huh? - 12/16/12 01:08 PM

I know that. But I had other Helvetica fonts in my work fonts set. Nue with a bazillion variation from ultra thin to extra black and from ultra condensed to expanded. Plus another regular Helvetica and a Helvetica Condensed. Been schlepping these fonts from one system to the next for a dozen years. Those are the sets I deleted from Suitcase.
Posted by: steveg

Re: Huh? - 12/16/12 01:09 PM

Quote:
You doubt me? mad
Undoubtedly! laugh
Posted by: Jim_

Re: Huh? - 12/16/12 02:37 PM

Do you have Helvetica Fractions? It's always been a problem.
Posted by: steveg

Re: Huh? - 12/16/12 03:11 PM

Nope. Never had it. I see from The Google it has a tendency to misbehave. I had Helvetica, Helvetica Compressed, Helvetica Narrow, and in Helvetica Nue there were three families each of regular, condensed, and expanded. An embarrassment of Helveticas! grin All gone now and good riddance.
Posted by: Acumowchek

Re: Huh? - 12/16/12 03:20 PM

But I don't want to use Ariel mad
wink
Posted by: NucleusG4

Re: Huh? - 12/17/12 06:08 AM

Arial.
Posted by: Acumowchek

Re: Huh? - 12/17/12 06:42 AM

Quote:
This post can no longer be edited because the maximum edit time has expired.


Damn!
Posted by: Papa

Re: Huh? - 12/17/12 06:52 AM

Perhaps you had mermaids on your mind when you were typing.
Posted by: yoyo52

Re: Huh? - 12/17/12 08:52 AM

Nah, not mermaids--aerie sprites.

Posted by: Papa

Re: Huh? - 12/17/12 10:32 AM

Interesting but I think I will stick with Ariel.
Posted by: MacGizmo

Re: Huh? - 12/18/12 01:12 PM

For what it's worth, you don't have to delete the entire Helvetica font family, just the plain/book version (possibly bold too, but I've not run into that). Same goes for Helvetica Neue. This is a problem in any app that uses WebKit (Safari, Mail, Google Chrome, etc.). The weird thing is that it's not consistent. I run into the problem daily at work where I'm forced to use Google Chrome. The Helvetica fonts on many websites turn to gibberish, but Safari loads them fine. Disabling all Helvetica fonts in our font manager fixes the problem.
Posted by: steveg

Re: Huh? - 12/18/12 01:26 PM

Only one of my clients uses Helvetica Nue as part of their graphic standards, and to be honest, the variations within the system font set are all I need. What I had was Helvetica Overload — like hunting chipmunks with a tank. So pulling that set out was as cathartic as it was beneficial to my system.