App/Util information needed

Posted by: papabill

App/Util information needed - 10/03/10 06:14 PM

Can anyone give me some ideas where to get free software for my 2 little G3 machines? I'm running OSX 10.2. I'm looking for Mac replacements for some Windoze applications. Mostly what I'm looking for is replacements for Office Suite (including Word, Publisher, Excel, Access, and PowerPoint). I also need replacements for MSMoney and MS FrontPage (or Macromedia DreamWeaver).

I'm also hoping to find an out-of-the-box BBS software (those of the gray hair should remember)

Thanks
Posted by: yoyo52

Re: App/Util information needed - 10/03/10 06:29 PM

NeoOffice for the Office substitute. Don't know about the other ones you need.
Posted by: papabill

Re: App/Util information needed - 10/03/10 06:33 PM

Thanks, but I'm looking for the free software
Posted by: polymerase

Re: App/Util information needed - 10/03/10 07:11 PM

Not sure if NeoOffice puts free in bold but I think it is the same price. For a Frontpage replacement I would just write straight HTML. It is definitely free, bold or no.
Posted by: papabill

Re: App/Util information needed - 10/03/10 08:10 PM

You are right, I saw another app available for 9.95, and thought that was it. Thanks
Posted by: NucleusG4

Re: App/Util information needed - 10/03/10 10:00 PM

Bookmark this. Everyone.
Almost 20,000 Mac apps.
By category.
Some free, some not.


http://osx.hyperjeff.net/Apps/
Posted by: padmavyuha

Re: App/Util information needed - 10/03/10 11:31 PM

NeoOffice is free (donationware) but the current version won't run on 10.2, I'm afraid.
Posted by: papabill

Re: App/Util information needed - 10/04/10 05:44 AM

Well, what is a good (free) DreamWeaver/FrontPage substitute? I've seen references to iWeb, but I'm sure that isn't free.
Posted by: MacBozo

Re: App/Util information needed - 10/04/10 07:10 AM

NeoOffice is free - open source.
Posted by: MacBozo

Re: App/Util information needed - 10/04/10 07:11 AM

I think that there are options to download older versions of NeoOffice.
Posted by: Jim_

Re: App/Util information needed - 10/04/10 07:36 AM

Originally Posted By: papabill
Well, what is a good (free) DreamWeaver/FrontPage substitute? I've seen references to iWeb, but I'm sure that isn't free.
iWeb isn't free, it's part of iLife, $79.

This works with 10.2.8. http://www.macupdate.com/info.php/id/15699/nvu

Don't know if this does. http://smultron.sourceforge.net/

Posted by: padmavyuha

Re: App/Util information needed - 10/04/10 03:26 PM

Originally Posted By: MacBozo
I think that there are options to download older versions of NeoOffice.

There was a bug in the OSX 10.2 installer which meant that it could delete the contents of your startup volume under certain circumstances (depending on what language you were installing in). One consequence of this is that the NeoOffice devs stopped providing a dl link for the version of NeoOffice that ran in 10.2. However, if you search their forum I remember someone posting a link to a copy on their own site. If you get no joy there, I'll ask around the other mods.

By the way, quite right, NeoOffice is free and opensource - when I wrote 'donationware' I meant it in the looser sense of 'free but you're encouraged to make a donation' rather than 'required to make a donation'.
Posted by: papabill

Re: App/Util information needed - 10/04/10 08:28 PM

So far I have found NVU for my web page building, and I'm loading Open Office 1.1.2 now (hopefully it will work for me). It's hard to find stuff for 10.2 (seems to be as out-of-date as me)
Posted by: MacBozo

Re: App/Util information needed - 10/05/10 05:22 AM

Doesn't Open Office need X-Windows (is that the right name?) to run on 10.2?
Posted by: papabill

Re: App/Util information needed - 10/05/10 05:54 AM

Originally Posted By: MacBozo
Doesn't Open Office need X-Windows (is that the right name?) to run on 10.2?


Yep, and for some reason it cannot find where X-windows is, so, of course, it won't run either. Oh, well. It seems that there is nothing available any more,
Posted by: MacBozo

Re: App/Util information needed - 10/05/10 05:59 AM

Do you have the 10.2 install disk? I believe X-Windows can be installed from it. Also, there used to be a download link on Apple's web site. It's also called X11. I see that it was not included until 10.3.
Posted by: papabill

Re: App/Util information needed - 10/05/10 08:10 AM

Originally Posted By: MacBozo
Do you have the 10.2 install disk? I believe X-Windows can be installed from it. Also, there used to be a download link on Apple's web site. It's also called X11. I see that it was not included until 10.3.


I'm so unfamiliar with the file structure of Mac that I can't figure out where things are, how to delete them, and how to make an application find something it needs.

I think I remember the install asking where X-Windows was, but I didn't know where to respond, so I'm sure I'm the problem there. Now I cannot even see all the files in the download folder of my PC from my iMac (last night I could see them and copied them over to my desktop till I got them installed and then deleted them.) Now I cannot even see the original files.

By the way, in Windoze, the F5 key refreshes the screen-is there a refresh key in "Macese"?
Posted by: MacBozo

Re: App/Util information needed - 10/05/10 08:18 AM

I still wonder why it is that a Mac user has no, or little, trouble using Windows, but a Windows user has so much trouble using the Mac OS. This isn't rocket science. Oh, this isn't pointed at you - just an observation.
Posted by: papabill

Re: App/Util information needed - 10/05/10 09:07 AM

Well, I'm very disappointed in myself for not picking it up quicker. As you say, any dummy can run windoze, but it takes a special individual to run Macs smile

I have another observation: back when 10.2 was the "top of the line", there HAD to be programs available for it. Where are they now? I cannot find anything worthwile that will run on 10.2. It's all 10.3 or better.
Posted by: MacBozo

Re: App/Util information needed - 10/05/10 09:13 AM

There was plenty, but most, if not all, have been through several upgrade cycles. I'd check eBay for specific titles. Otherwise, you'll be limited to shareware and freeware alternatives.
Posted by: papabill

Re: App/Util information needed - 10/05/10 09:20 AM

Originally Posted By: MacBozo
There was plenty, but most, if not all, have been through several upgrade cycles. I'd check eBay for specific titles. Otherwise, you'll be limited to shareware and freeware alternatives.


Yeah, that's what I'm gonna have to settle for. No money in the budget for this hobby. If we could afford a new Mac, that'd be different. My wife would loosen the purse strings a little. wink
Posted by: yoyo52

Re: App/Util information needed - 10/05/10 09:43 AM

I find Windows almost impossible to use, I'm afraid. It's entirely counterintuitive. The problem that Windows users seem to have with the Mac is that they expect complexity where they get simplicity. If you don't know where something is, search for it, command-F in 10.2, I think. If something is an application would one not expect to find it . . . wait for it . . . in the Applications folder? or its subfolders, like Utilities? It ain't so hard.
Posted by: papabill

Re: App/Util information needed - 10/05/10 10:43 AM

I finally got OpenOffice 1.1.2 installed (I think), but it still will not run. At the VERY end of the installation, it had a dialog box that suggested if it would not start, type the following lines into Terminal:

setenv DISPLAY localhost:0
setenv DYLD_LIBRARY_PATH/Applications/OpenOffice.org1.1.2/program:/Applications/OpenOffice.org1.1.2/program/filter
cd /Applications/OpenOffice.org1.1.2/program
sh soffice

I did that, but got an error "Set display environment variable, use -display option or check permissions of your X-Server (See 'man x' resp. 'man xhost' for details)"

I tried using "setenv -DISPLAY localhost:0", but got the same error. I also tried to check 'man x' and 'man xhost' but got "No manual entry for x" and "No manual entry for xhost"
Posted by: MacBozo

Re: App/Util information needed - 10/05/10 11:58 AM

It's probably looking for X Windows (X11). It needs that windowing environment to run.
Posted by: papabill

Re: App/Util information needed - 10/05/10 12:09 PM

Yeah, but where is it? I can't find a thing. I've looked in Applications, Utilities and even System
Posted by: MacBozo

Re: App/Util information needed - 10/05/10 12:31 PM

10.2 does not install it. It was only included in 10.3 and later which placed it in the Applications folder.

This looks promising:

X11 for Mac OS X 1.0
It's the blue download button, not the green one.

I don't see any OS requirements/compatibilities listed, but it is dated 2003. Anyone else have a clue?
Posted by: papabill

Re: App/Util information needed - 10/05/10 12:46 PM

"Hmm, the page youíre looking for canít be found." wink

Well, since this machine is set up to run 10.3, I've found one on eBay that I've put a bid on (just hafta do without ice cream bars for a while). Maybe it'll work then.
Posted by: MacBozo

Re: App/Util information needed - 10/05/10 12:50 PM

Loads right up for me. Browser incompatible?
Posted by: papabill

Re: App/Util information needed - 10/05/10 12:52 PM

Originally Posted By: MacBozo
Loads right up for me. Browser incompatible?
(Nope, IE 8)

I found the site you mentioned, but when it comes to the download, it isn't there.
Posted by: MacBozo

Re: App/Util information needed - 10/05/10 12:54 PM

Oh, I see. It's no longer available from Apple (where the download link takes you).

Look for Mac OS 10.3 and upgrade to that - seems to be your only option to get X11 and anything else that might be useful.
Posted by: papabill

Re: App/Util information needed - 10/05/10 12:56 PM

Oh, well. Just my luck. I'm re-installing OS X 10.2 (just in case I missed it.) What the heck, I can't mess anything up; I can't find programs to run.
Posted by: MacBozo

Re: App/Util information needed - 10/05/10 12:57 PM

It wasn't included with 10.2. 10.3 and later.
Posted by: papabill

Re: App/Util information needed - 10/05/10 12:59 PM

HeHeHe-well, I got nothing better to do
Posted by: carp

Re: App/Util information needed - 10/05/10 03:03 PM

do without ice cream bars for a while


Noooooo not the ice cream bars. Find something else.
Posted by: Jim_

Re: App/Util information needed - 10/05/10 05:05 PM

Okay, if you feel like getting your geek on. grin The X11 for 10.2.8 was called beta 3 by Apple, make sure you update to 10.2.8. It was based on XFree86 4.2.1. Click here ftp://ftp.xfree86.org/pub/XFree86/4.2.1/ A Finder window will eventually open. Go to binaries and drag FreeBSD to the desktop, it will copy.

Open Terminal.app. Type in sudo {space} sh {space} and drag the Xinstall.sh file to the terminal window, hit Return, enter your password when prompted. {space} = space, don't type {space}.

Here's the page I got it from http://www.xfree86.org/downloads.html

Here's the install notes, http://www.xfree86.org/4.2.1/Install.html I simplified the Terminal instructions above.

The XFree86 4.3.0 version may work, don't know, but I found that Apple's version for 10.2.8 was XFree86 4.2.1.

You may need this http://www.finkproject.org/doc/x11/run-xfree86.php to start X11 after installing. Read 4.2 Mac OS X + XFree86 4.x.y

Reboot the machine after installing XFree86.

Since you don't seem adverse to reinstalling the system you really can't break much.
Posted by: papabill

Re: App/Util information needed - 10/06/10 06:10 AM

Well, after spending HOURS last night following the instructions to the letter, and again this morning, I'm still getting the same error: "You need to download the 'extract' (or 'extract.exe') utility and put it in this directory." It's already in that directory, but after several attempts to make it work, I decided to put it in the Utility directory along with Terminal-but it still didn't help.

I guess I'll just have to learn to live with TextEdit and whatever little other "office-like" programs I can find on the "freebie" Mac software sites.

Thanks anyway

(Thankfully 10.3 is on it's way smile )
Posted by: MacBozo

Re: App/Util information needed - 10/06/10 06:34 AM

Usually, a .exe file is Windows only, isn't it?
Posted by: papabill

Re: App/Util information needed - 10/06/10 06:53 AM

Originally Posted By: MacBozo
Usually, a .exe file is Windows only, isn't it?


I woulda thought so, but not being that familiar with Mac, I wasn't sure. Anyway, I put BOTH of them in the Utility directory with Terminal (just to cover all bases-after all, it said to download "the 'extract' (or 'extract.exe') utility") but it didn't do any good.
Posted by: Jim_

Re: App/Util information needed - 10/06/10 07:22 AM

Originally Posted By: papabill
Well, after spending HOURS last night following the instructions to the letter, and again this morning, I'm still getting the same error: "You need to download the 'extract' (or 'extract.exe') utility and put it in this directory." It's already in that directory,
I got that too, I'll look into it in the next day or so, busy today and tomorrow.
Posted by: Jim_

Re: App/Util information needed - 10/06/10 07:23 AM

Originally Posted By: MacBozo
Usually, a .exe file is Windows only, isn't it?
No, welcome to the dirty underbelly of Unix. grin
Posted by: papabill

Re: App/Util information needed - 10/06/10 09:32 AM

I was looking for some more software and found some in the "Native OS X" folder that were Debian and Suse distributions. Will these actually work under OS X 10.2.8? (yeah, I upgraded)
Posted by: Phosphor

Re: App/Util information needed - 10/07/10 11:29 AM

Originally Posted By: papabill
So far I have found NVU for my web page building...


NVU is a little out-of-date, and not being updated anymore.

Better you should get Kompozer (basically, it's the same app):

http://nvu.wikispaces.com/NVU+vs.+KompoZer--an+explanation
Posted by: papabill

Re: App/Util information needed - 10/27/10 01:44 PM

Is there a 10.2.8 replacement for Yahoo Messenger? Yahoo doesn't have anything listed for anything earlier than 10.3
Posted by: Jim_

Re: App/Util information needed - 10/27/10 05:36 PM

Does 10.2.8 have iChat? I forget.
Posted by: carp

Re: App/Util information needed - 10/27/10 05:54 PM

Here ya go. Your in the middle somewhere laugh

History

iChat was first released in August 2002 with the introduction of Mac OS X v10.2. It featured integration with the Address Book and Mail applications and was the first officially-supported AIM client that was native to Mac OS X (the first-party AIM application at the time was still running in Classic emulation).
[edit]iChat AV
In June 2003, Apple announced iChat AV, the second major version of iChat. It added video and audio conferencing capabilities based on the industry-standard Session Initiation Protocol (SIP). The final version of the software was shipped with Mac OS X v10.3 and became available separately on the same day for Mac OS X v10.2 for $29.95.[2]
Posted by: papabill

Re: App/Util information needed - 10/29/10 09:09 AM

Is there a php that will run on this 10.2.8? Apache seems to be doing fine. What about MySql?

Thanks
Posted by: Jim_

Re: App/Util information needed - 10/29/10 09:59 AM

You'll find info here. First and fifth hit are what you need probably.
Posted by: papabill

Re: App/Util information needed - 10/30/10 07:58 PM

Originally Posted By: Reboot
First and fifth hit are what you need probably.


Thanks. I found out that PHP is already in 10.2.8, it just has to be activated. Now I've got to find MySql 4.x (because that seems to be the only one that will work with 10.2.8).

Hey, if I haven't already said it, I appreciate all the help you've been with this 'dinosaur' of mine. I just wish I could find more useable software.
Posted by: papabill

Re: App/Util information needed - 11/01/10 04:42 AM

Been suggested Linux best for this 'beast'

Ideas? Which distro?
Posted by: sarah189

Re: App/Util information needed - 11/24/10 02:48 AM

You can download NeoOffice from its official site; neooffice.org/neojava/en/download.php