Previous Thread
Next Thread
Print Thread
Hop To
How to create fusion drive under Yosemite #625647 12/09/14 07:54 PM
Joined: Dec 2014
Posts: 1
V
valiant Offline OP
OP Offline
V
Joined: Dec 2014
Posts: 1
I'm trying to create a new fusion drive for my old Mac Pro running Yosemite.

I did this successfully before, under either Mavericks or Mountain Lion.

But Yosemite has introduced a new wrinkle.

Booting from an external Yosemite install, and using Disk Utility I formatted the 120GB Kingston SSD and installed Yosemite on it because I wanted a Recovery Partition. That worked as expected.

Code:
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *120.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS 120                     119.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3


Then I formatted the 4TB Seagate and got something unexpected. Disk Utility created a Core Storage volume, and I can't do anything with it, except partition it in two, which I don't want to do.

Code:
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *4.0 TB     disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:          Apple_CoreStorage                         4.0 TB     disk1s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk1s3
/dev/disk3
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS 4tb                    *4.0 TB     disk3
                                 Logical Volume on disk1s2
                                 49223D39-E0AD-47B0-A216-5402E2F89F5D
                                 Unencrypted


As you can see, disk1s2 has been converted to coreStorage disk3

There's nothing that can be done with that. Disk Utility no longer presents a Format option on the drive (the button is gone from the interface) - you can't even go back to a FAT32 format.

And coreStorage is not able to create a fusion drive.

Code:
Error creating CoreStorage Logical Volume Group: The target disk is already in use by Core Storage (-69753)


I tried it with the whole disk, that didn't work:

Code:
$ diskutil cs create KingstonFusion disk0 disk1
Started CoreStorage operation
Unmounting disk0
Repartitioning disk0
Unmounting disk
Creating the partition map
Rediscovering disk0
Adding disk0s2 to Logical Volume Group
Unmounting disk1
A problem occurred; undoing all changes
Initialized /dev/rdisk0s2 as a 111 GB case-insensitive HFS Plus volume with a 16384k journal
Mounting disk
Error: -69888: Couldn't unmount disk


And I tried it with the coreStorage volume - also no go:

Code:
$ diskutil cs create KingstonFusion disk0 disk3
Error creating CoreStorage Logical Volume Group: Stacked Core Storage Sets are not supported (-69754)


Does anyone have any idea how I can use these two drives to create a Fusion drive?

Or else how I can revert the 4tb coreStorage volume to Apple HFS?

Thanks.

Re: How to create fusion drive under Yosemite [Re: valiant] #625654 12/10/14 01:36 AM
Joined: Apr 2002
Posts: 15,077
Reboot Offline
Muhahahaha
Offline
Muhahahaha
Joined: Apr 2002
Posts: 15,077
Maybe this will help. Seems something changed in regards to core storage. The article below is about partitions but it may apply to your case.

http://awesometoast.com/yosemite-core-storage-and-partition-woes/

Re: How to create fusion drive under Yosemite [Re: valiant] #625796 12/15/14 12:38 AM
Joined: Dec 2014
Posts: 1
D
dfuerpo Offline
Offline
D
Joined: Dec 2014
Posts: 1
I also ran into this problem today (on my 2010 Mac Pro) and think I found a solution (although the fusion drive seems to be using the HDD more than it should; more on that below). I wanted to upgrade my fusion drive (a 120 GB SSD and 1 TB HDD) from mavericks to yosemite doing a clean install because I had done update installs ever since snow leopard. I thought it might get rid of some of the accumulated crud. Anyway, after backing up I deleted the core storage volume and then deleted the cs logical volume group. I then did an install of yosemite on the 1 TB HDD so I could have a recovery partition. Thatís when I found what you found, that a logical volume had been created. I knew if I deleted the volume it would reformat the HDD so I did some snooping on core storage commands. I found a command to add a disk to an existing lvg and it worked. The command is:
diskutil coreStorage addDisk lvgUUID DeviceName

where DeviceName is the device you want to add (mine was disk3s2, the data partition on the SSD). Note that lvgUUID is the ID of the logical volume group. This added the drive to the lvg but I then noticed that the size of the logical volume was wrong, only reflecting the size of the HDD. I broke out another command to expand the size of the volume:
diskutil coreStorage resizeVolume lvUUID size

Note that lvUUID is the logical volume ID (not the volume group). I also found that the size parameter cannot be a percentage (like 100%). I had to give it an actual size, in my case 1.1TB. Anyway this all seemed to work and I was then able to install Yosemite on the newly expanded volume.

One caveat, although the volume boots without problems, it seems that the HDD is working more than it use to under Mavericks and the boot time is not nearly as fast. I donít know if over time coreStorage will move system files to the SSD like it should or if things have fundamentally changed with Yosemite and DIY fusion drives using third party SSDs. The jury is still out, but my paranoia about Apple is growing.

Also interesting, I recently upgraded my MacBook Pro from Snow Leopard to Yosemite (not a clean install) and did not get a coreStorage volume on the single disk. StrangeÖ


Moderated by  Acumowchek