Thank you Gizmo. I am now back in business after following your advice.
FF has a setting in Content-Fonts under the Advanced button, to override page fonts or not BTW.

I enabled this option. I also set the minimum font to 12pts. I now use FF zoom function.

Also, you might want to upgrade to Firefox 4. It's much faster, more stable and has a host of new features.

I do not want to update to FF4 just yet. One of my add-ons is not compatible with it.