This stolen from MacFixIt (incase it's gone when you visit mfi)<br><br>Troubleshooting Mac OS X 10.2.8: Ethernet connections; Dual Display configuration; Permissions problems; more <br><br>Ethernet connections Perhaps the most widely reported problem reported after updating to Mac OS X 10.2.8 is loss of network access. It appears that in most cases, the failure is happening because DHCP self-assigns an IP address. <br><br>In some cases, 100 Mbps Ethernet continues to work, but the 10 Mbps mode is disabled. George Warner writes "The Mac OS X 10.2.8 update installed fine but I lost networking including ability to talk to my Apple Airport Extreme. After some experimenting, I was able to determine that my Mac (Dual-500 G4) was not able to talk to my 10 Base-T network. 10 Base-T is the least common denominator on my LAN. I require it for some other devices. Apparently, my updated Mac is stuck at 100 Base-T. A hub which provides a 10 to 100 bridge was able to band-aid my problem." <br><br>The solution is to revert the AppleGMACEthernet.kext from the new version (1.3.0) to the 10.2.6 version (1.2.4) and reboot. This file is located in System/Library/Extensions. You can pull this file from an older Mac OS X system that has not yet been updated, then replace it by booting into Mac OS 9 and overwriting the old file (which you should back up, just in case). <br><br>Alternatively, a poster on Apple's Discussion boards has uploaded the old .kext file to his Web server. <br><br>Of course, the main problem is that many readers who need this fix are not able to access the Internet after performing the Mac OS X 10.2.8 update. If you know some fellow Mac users who might be experiencing the issue, you may want to bring them the old AppleGMACEthernet.kext file on a CD. <br><br>Also, it is not yet known what other problems might be caused by using the old .kext file with the new version of Mac OS X. <br><br>System modifications/haxies Several readers report problems with haxies and other system modifications. The shareware utility Transparent Dock, in particular, no longer works for some readers. <br><br>FireWalk X2 also apparently seems to be losing functionality for some readers after the update. <br><br>UPDATE: Pliris Software, creator of FireWalk X2, told us "Apple removed a function from the kernel that we used to detect the current processor capabilities which is why our KEXT doesn't load on Mac OS X 10.2.7 or later. Yesterday we released Firewalk X 2 2.2.8 which corrects this problem, among others." <br><br>Dual Display configuration MacFixIt reader Graham Jones, along with a handful of other readers report that they had to reset their monitor preferences after installing Mac OS X 10.2.8. "My Dual G4/1.25 with Mac OS X 10.2.8 forgets screen sizes and reverses the arrangement of the two monitors." <br><br>Permissions problems One MacFixIt reader writes "After updating to Mac OS X 10.2.8, I am unable to use Disk Utility to repair permissions. About a minute after starting repair permissions, the screen goes black and the system is completely locked up. I've been troubleshooting this for about four hours with no luck." <br><br>Several other readers have since corroborated this issue. <br><br>The solution is to boot from the Mac OS X 10.2 CD (or another, sans-Mac OS X 10.2.8 volume) and then run repair permissions. <br><br>I can repair permissions by booting from the Jaguar CD. <br><br>Keyboard/mouse problems MacFixIt reader Ben Rosenthal writes: <br><br>"Keyboard and Mouse preference panes have been combined in Mac OS X 10.2.8, as in Panther. And, I seem to have lost trackpad support on my Lombard 400. I ran the update late last night, but only noticed the loss this morning, as my occasion to use the trackpad is minimized by my Apple Pro Mouse. However, I have occasion, e.g., to option click a link in Safari to download, and I use the trackpad button for this action." <br><br>UPDATE: Rosenthal now writes "I restarted into single user mode to run fsck (Ed.- hold down the shift key at startup and type /sbin/fsck -y ). Repaired a handful of orphaned indirect nodes, in addition to two or three other problems. Restarted once more to login and the trackpad worked. <br><br>Updates: (9:30 AM PDT) <br><br>Icons not appearing Several readers have reported problems with icons not appearing properly. Repairing disk permissions with Apple's Disk Utility seems to fix most of the broken icons, while others can be manually restored via Mitch Wayne's method: <br><br>"I had to use the Get Info panel to tell the system what application to use to open the doc, and then perform a Change All to fix all similar docs." <br><br>Linksys Router needs new firmware It appears that Mac OS X 10.2.8 requires the the latest version of Linksys' router driver software for proper operation. Peter Hillman writes <br><br>"I updated my Linksys Router BEFSR41 with their latest firmware version, 1.45.7. (I had 1.45.6). The firmware version fixes the following: <br><br>* Supports multi-L2TP-pass-through<br>* Supports DHCP relay agent<br>* Fixed fragmented packets arriving out of order.<br><br><br>"After updating the router, I powered everything down. I powered up the router, did a reset by pushing the reset button until the red light came on. Then I powered up my cable modem and waited for a signal. After I had a signal, I reset the router again. Then I powered up my PowerBook and everything works again. I launched Explorer and my <br><br>
_________________________
The Graphic Mac - Tips, reviews & more on all things OSX & graphic design.