I tried to download Mountain Lion 10.8.5 and was informed it wasn't compatible with my computer. Curses, foiled again! Apple says that 10.6.8 is required and that's what it has.
_________________________
Old farts, the hidden caulk of civilization. Jim Atkinson