Not sure which of the settings I'd fiddled with
did the trick, but the error message is GONE
and I have 23.6GBs of FREE Storage Space in iCloud!

I'd turned off "Back-Ups" in "Settings"

I plugged the iPhone into iTunes to check that
the settings were still set to
"Back-Up To This Computer"

Logged Out Of then back Into iCloud

Quit iTunes, Restarted the Computer

and when I went back into "Settings"
everything was back to normal! laugh

Now I have to decide
whether to burn down my kitchen...
...or clean up the mess I made trying to
learn how-to make FUNNEL CAKES. sick