The plot thickens:

Google Earth 6 places the Google Earth Web Plug-in in root/Library/Internet Plug-ins.

GE 7 places it in User/Library/Internet Plug-ins.

Looking at my Console System Log, GE 7 is having trouble determining which plug-in to use.

Even more interesting: Seems to be a call JAVA applet error which the JAVA Security update may have closed that down.

System Log output for GE 7 launch:

Quote:
Apr 17 20:38:21 mail198 [0x0-0x184184].com.Google.GoogleEarthPlus[5778]: Intrinsic Alchemy v3.5 Beta-1219 (Static/Production)
Apr 17 20:38:21 mail198 [0x0-0x184184].com.Google.GoogleEarthPlus[5778]: Built by keyhole-build on Wed Dec 19 00:00:00 2012
Apr 17 20:38:23 mail198 Google Earth[5778]: invalid drawable
Apr 17 20:38:26: --- last message repeated 1 time ---
Apr 17 20:38:26 mail198 Google Earth[5778]: Cannot find executable for CFBundle 0xd51ce80 </Applications/Google Earth.app/Contents/PlugIns/imageformats> (not loaded)
Apr 17 20:38:26 mail198 Google Earth[5778]: Cannot recognize type of executable for CFBundle 0xd513b30 </Library/Internet Plug-Ins/MRJPluginCarbon.plugin> (not loaded)
Apr 17 20:38:27 mail198 Google Earth[5778]: Error loading /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/MacOS/JavaAppletPlugin: dlopen(/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/MacOS/JavaAppletPlugin, 265): no suitable image found. Did find:
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/MacOS/JavaAppletPlugin: mach-o, but wrong architecture
Apr 17 20:38:28 mail198 Google Earth[5778]: Error loading /Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin/Contents/MacOS/AdobePDFViewerNPAPI: dlopen(/Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin/Contents/MacOS/AdobePDFViewerNPAPI, 262): no suitable image found. Did find:
/Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin/Contents/MacOS/AdobePDFViewerNPAPI: mach-o, but wrong architecture
Apr 17 20:38:28 mail198 Google Earth[5778]: Cannot recognize type of executable for CFBundle 0x11c57e50 </Library/Internet Plug-Ins/DRM Plugin.bundle> (not loaded)
Apr 17 20:38:28 mail198 [0x0-0x184184].com.Google.GoogleEarthPlus[5778]: NP_Init called
Apr 17 20:38:28 mail198 Google Earth[5778]: Error loading /Library/Internet Plug-Ins/Scorch.plugin/Contents/MacOS/Scorch: dlopen(/Library/Internet Plug-Ins/Scorch.plugin/Contents/MacOS/Scorch, 262): no suitable image found. Did find:
/Library/Internet Plug-Ins/Scorch.plugin/Contents/MacOS/Scorch: mach-o, but wrong architecture
Apr 17 20:38:28 mail198 [0x0-0x184184].com.Google.GoogleEarthPlus[5778]: objc[5778]: Class GoogleEarthPluginBundleDummyType is implemented in both /Applications/Google Earth.app/Contents/MacOS/../Frameworks/libnpgeinprocessplugin.dylib and /Library/Internet Plug-Ins/Google Earth Web Plug-in.plugin/Contents/MacOS/libnpgeplugin.dylib. One of the two will be used. Which one is undefined.
Apr 17 20:38:28 mail198 [0x0-0x184184].com.Google.GoogleEarthPlus[5778]: NP_Init called
Apr 17 20:38:48 mail198 [0x0-0x184184].com.Google.GoogleEarthPlus[5778]: -- GetMIMETypeList() called

Launching GE 6 to see what that generates....

Looks the same to me:
Quote:
Apr 17 20:45:03 mail198 [0x0-0x188188].com.Google.GoogleEarthPlus[5795]: Intrinsic Alchemy v3.5 Beta-0404 (Static/Release)
Apr 17 20:45:03 mail198 [0x0-0x188188].com.Google.GoogleEarthPlus[5795]: Built by keyhole-build on Wed Apr 4 00:00:00 2012
Apr 17 20:45:03 mail198 [0x0-0x188188].com.Google.GoogleEarthPlus[5795]: INFO: Using OpenGL Context.
Apr 17 20:45:06 mail198 [0x0-0x188188].com.Google.GoogleEarthPlus[5795]: Qt: QCursor: Cannot create bitmap cursor; invalid bitmap(s)
Apr 17 20:45:09: --- last message repeated 7 times ---
Apr 17 20:45:09 mail198 [0x0-0x188188].com.Google.GoogleEarthPlus[5795]: NP_Init called
Apr 17 20:45:10 mail198 Google Earth[5795]: Error loading /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/MacOS/JavaAppletPlugin: dlopen(/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/MacOS/JavaAppletPlugin, 265): no suitable image found. Did find:
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/MacOS/JavaAppletPlugin: mach-o, but wrong architecture
Apr 17 20:45:10 mail198 Google Earth[5795]: Error loading /Library/Internet Plug-Ins/Scorch.plugin/Contents/MacOS/Scorch: dlopen(/Library/Internet Plug-Ins/Scorch.plugin/Contents/MacOS/Scorch, 262): no suitable image found. Did find:
/Library/Internet Plug-Ins/Scorch.plugin/Contents/MacOS/Scorch: mach-o, but wrong architecture
Apr 17 20:45:10 mail198 Google Earth[5795]: Cannot recognize type of executable for CFBundle 0x1f0f3d70 </Library/Internet Plug-Ins/DRM Plugin.bundle> (not loaded)
Apr 17 20:45:10 mail198 Google Earth[5795]: Cannot recognize type of executable for CFBundle 0x1f0f4390 </Library/Internet Plug-Ins/MRJPluginCarbon.plugin> (not loaded)
Apr 17 20:45:10 mail198 Google Earth[5795]: Error loading /Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin/Contents/MacOS/AdobePDFViewerNPAPI: dlopen(/Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin/Contents/MacOS/AdobePDFViewerNPAPI, 262): no suitable image found. Did find:
/Library/Internet Plug-Ins/AdobePDFViewerNPAPI.plugin/Contents/MacOS/AdobePDFViewerNPAPI: mach-o, but wrong architecture
Apr 17 20:45:11 mail198 [0x0-0x188188].com.Google.GoogleEarthPlus[5795]: objc[5795]: Class GoogleEarthPluginBundleDummyType is implemented in both /Applications/Google Earth 2.app/Contents/MacOS/libnpgeinprocessplugin.dylib and /Library/Internet Plug-Ins/Google Earth Web Plug-in.plugin/Contents/MacOS/libnpgeplugin.dylib. One of the two will be used. Which one is undefined.
Apr 17 20:45:11 mail198 [0x0-0x188188].com.Google.GoogleEarthPlus[5795]: NP_Init called
Apr 17 20:47:01 mail198 [0x0-0x188188].com.Google.GoogleEarthPlus[5795]: -- GetMIMETypeList() called


Still, GE 6 launches with graphics/imagery and GE 7 does not.
_________________________