Thanks! So, it might be a problem with the current version. If I go back to the "older" version, I should turn off Google updates then.
_________________________