Reboot?

Try tossing your Google Earth cache folder in home/Library/Caches and/or the com.Google.GoogleEarthPlus.plist in Preferences.