QUESTION I THINK I KNOW THE ANSWER TO.
I am running a g5 on version 10.5.8.
Firefox is browser of choice
I keep getting notices that Java needs to update to run certain (MOST) videos. If I try to update I get a message that the current version will not run on my machine.
Am I correct in guessing that those of us still running older Macs (non-Intel) are basically F'd or is there some work around or different software I missed out on
Thanks, choker