Is now busted on older iOS versions.
Just finished updating Apple TV, and sure enough, my 2G iPod needs iOS 5 or better to use the remote.
Thanks, Obama. mad