Double check your settings in Settings, Notifications.