Click to enlarge...

I'm seeing this ONLY in Safari on my Mini and on my MBP, but not under the icons. Not in Firefox Aurora or Google Chrome. I've check and confirmed language settings in system and Safari prefs, and iCloud settings. Have repaired permissions, restarted, cleared caches and history... No joy.

Any ideas?

Also, I've just enable PhotoStream on both Macs and my iPhone, so shouldn't I see that icon on the iCloud home page as well?
_________________________