Conceptually, the simplest way to do this is to go to iTunes --> Preferences --> Advanced and reset the Media Folder location to the default (which will be in your User folder on the boot drive). Then clear your library and reimport.

To be sure it's set, shut down, turn off the external drive and start up the machine again. Then check the Advanced tab in iTunes Prefs to make sure it's using the reset location (it will be -- an annoyance I have is it resetting to the default whenever I restart since my externals boot-up slower than the internals -- so you shouldn't have any issues there ;-)