Hi all,

first-timer here hoping for help from the hive-mind!


I have a late 2010 MBA (3,1) running Mountain Lion

SMC 1.67f9
Boot ROM (EFI) MBA31.0061.B07

I bought it from a friend with Bootcamp/Windows installed and everything was fine.

Then I decided to be clever and free up some space by erasing the bootcamp partition via Disk Utility.

As soon as I did that, the built in keyboard and trackpad haven't worked. No light on Caps lock button. Power button is the only one that works. USBs are OK. No other problems.

I'm thinking the EFI has been slightly corrupted or a boot setting is still looking for Windows drivers for those two IO devices.


What I've tried:

Took it to Apple Genius Bar - they replaced the trackpad controller board (I told them that wouldn't fix it). No change.

Reset SMC, PRAM multiple times. No change

Upgraded to Mountain Lion from Snow Leopard. No change

Installed rEFIt - tried some utils. No change

Software update doesn't find any required updates.

Tried reinstalling recommended EFI (2.3, I think) - error message is (This software is not supported on your device)

Tried reinstalling SMC - same as above


Help!! - I'm at my wit's end. I'm convinced that if I can flash/reload the correct EFI, it will fix the problem. Is there a terminal command that'll do it? I'm moderately OK using the Terminal.


Thanks for reading this.