SSL is Secure Sockets Layer, a method of encrypting your email password when the device queries the server if you have mail. In your case SSL is on for Outgoing, off for Incoming.

For outgoing mail settings go to Settings/Mail, Contacts, Calendars/Your Account/Outgoing Mail Server-SMTP button/Primary Server.

Outgoing should look like the pic below except Host Name is smtp.cox.net, User name is your Cox email address.



For incoming Settings/Mail, Contacts, Calendars/Your Account/ Click the Advanced button just above Delete Account. SSL should be off there, Port should be 995. The only difference from the pic below is that SSL will be off, and Authentication never seems to show Password but if you choose Password it uses it. If you're receiving mail okay you shouldn't have to change anything other than the port maybe.

Make sure you click Done in the upper right if you change any settings.