Quote:
Is there a way to turn Siri off from intercepting voice mail ?

Settings --> General --> Siri --> Off ;-)