Glad it worked out for you. I use it to connect to Windows machines, and a wide range of OS X from 10.4 to 10.8. I don't know why Apple with all of its money can't make something just as compatible. They do know what's best for us I guess. LOL.