OK, I've plugged it into my USB Hub at work (No comments please! blush), and it showed up in iTunes no problem. It's not the cable.

I don't think I've EVER had it show up on my desktop. I didn't know it was supposed to. Am I missing a setting?

I'm going to recreate my Libraries from scratch. I'm sure it's human error.
Which human, I don't know. wink

Edit: I see Finder Prefs has a check mark to show Cd's, DVD's and iPods. I have always had that checked, but I don't think that applies to an iPod touch.


Edited by Acumowchek (06/20/11 03:14 PM)