You have 10.2.8 up and running on that, right? Can you score a copy of AppleWorks 6? It has all you would need to create a database and spreadsheet and works quite well - even in 10.6.4. It's old and now unsupported, but it still works quite well.
_________________________