Well, you definitely need a different IP address for each computer, but the iMac should be sending it to the laptop for you if you have internet sharing turned on. Also make sure you have "Airport" selected in the network panel on the laptop with DHCP in the configure settings. Then in the "Airport Tab" make sure it says to join specific network and your name and password for the network are correct. If it doesn't work, try setting it to use the "network with strongest signal" instead.<br><br><br>Visit Me At My .Mac Site
_________________________
The Graphic Mac - Tips, reviews & more on all things OSX & graphic design.