Originally Posted By: "iBookdude458"
i know it will work because it says its only compatible with dual-core and quad-core G5s which mine is a Dual-core.

I want to say watch out for that because i made that mistake, make sure yours is a late 2005 model just in case