Have you checked the jumper settings?