Well I tried installing Linux on the iPod and not knowing what gen I had it didn't work. The bootloader started up but froze up. Come to find out I have the 5.5 gen iPod that is not compatible for the iPod Linux since it uses a different CPU. Maybe after a few months some one will port it over.
_________________________
To live is to let die