I just installed an 80GB Samsung hard drive in my Titanium Powerbook (G4). Samsung assures me the drive is compatible with the Powerbook. But when I tried to re-install OS X, the system did not recognize the new HD. I booted laptop as a FireWire Target, and was able to run disk utilities on the new drive, and it tested out fine. Mounted this way, I was able to store and retrieve data from the drive. I was also able to install OS X on the drive and boot my desk top computer, using this drive. But when I disconnected the FireWire and tried booting the lap top, it crashed and I got kernel errors.

I also booted the Powerbook from CD, with the new drive in it, using "Drive 10" and "TechTools Pro" utility software, and they all say the drive is working fine. But as soon as I try to boot from the OS X install CD, it crashes again with the kernel errors.
I spent hours on the phone with Apple support, but made no progress, and they finally said I had to contact Samsung. Samsung keeps telling me the problem is in the "BIOS"! So, I seem to be getting nowhere!


Can anyone help me????

Thanks