Thanks for the suggestion - but the thing is, the OSX printer service tells me my printer's plugins (e.g. duplex) are the wrong architecture for 10.6.x and I need to contact the driver developers for an update.
_________________________
If it's brokenless, don't suffix it...