In the Airport Network settings there is an option to set your wireless network as a preferred network. I forget how to get to it in 10.3.x and don't have one available, but I'd say that's the problem in your setup. I think it's an Options or Advanced button you have click to get there.