Actually my iTunes DOES sort by Artist > Album > track #. In fact, no matter which of the Album sorts I use, tracks are always in order by #. This works for 2-disc compilation sets as well: disc one is listed with all tracks in order, followed by disc two.

So just sort by Album and you should be fine.

if not, then maybe something else is wrong with just that particular album? Are track numbers messed up? (That can be fixes in Get Info.)

Note that in Get Info > Sorting you can define a "hidden" song name, album name, artist name, etc. that is used JUST for sorting, and not displayed. That could give you a workaround if you can't find the cause of the problem.

(Also note that in Get Info > Options there's a Gapless Album checkbox if you need songs to blend smoothly into one without gap or overlap.)
_________________________
nagromme

STROGG: Change We Can Believe In
TeamMacOSX.org