Neil is the real deal... 9.1 and broadband are the only way to go, that is, if those are even options for you... some people have some softwares (though i can't remember which those are) that are broken by 9.1 and not everyone can get broadband in their area. but 9.1 is by far and away the best, it even clobbers 9.04 badly and 9.1 is soooo stable. a dream.<br><br>