I believe they will not work with any existing machines, only the new PowerBooks... however, I'm sure Apple will be updating all their machines to have the new connectors to use Airport Extreme.<br><br><br>Visit Me At My .Mac Site
_________________________
The Graphic Mac - Tips, reviews & more on all things OSX & graphic design.