Open the Network prefs, select Network Port Configurations, drag AirPort to the top, Built-in Ethernet below it, check both, and uncheck Internal Modem. <br><br>In the AirPort pane, select Join a Specific Network, and make sure you have the right network and password entered. And under the TCP/IP tab, make sure those settings are entered correctly.<br><br>See if any of that that helps.<br><br>
_________________________