Hmm... I may be out on a limb here, but are your PCs joining another network? One operated by your neighbour purhaps?<br><br>Either that, or your PCs are set to share their internet connection, and they are connecting to each other instead of the base station. Internet sharing should be turned off on your PCs and Macs.<br><br><br>