Yeah...I switched to smtpauth the day they made the change, and like yourself, I have the spamblocker turned off. <br><br>