The story so far... My G4 533 DP is new. Out of the box installed iMovie 2 connected DV cam TRV 900 and all worked fine. Had done a fair bit of importing and then did some transitions. It crashed... When I turned back on I could do everything via firewire other than import. I thought...small "ok, software instability". I upgraded iMovie 2.01 to 2.03 The Apple site recommended a Firmware upgrade which I did. Hey presto every thing worked and I was back up and running. So there I am happi;y importing clips into iMovie and my doorbell rings. It's a friend...so after a chat and a cup of tea I'm back at the G4...and guess what? it wouldn't import into iMovie. I got to thinking that if there are known problems with G4,OS 9.1 and DP's,and energy saver/sleep mode, there might be an issue with the TRV 900 and it's sleep function somehow affecting the G4. So... I binned iMovie, reinstalled OS9.1, reinstalled iMovie, but no...nothing now seems to work. As I said earlier...the odd thing is I can import live with the camera in camera mode, but not in VCR.Odd huh ? <br><br><br>G4 533 DP OS 9.1 384Mb Ram 38 Gb +57Gb Hard drive. Firewire 2.8 <br>Latest firmware update. iMovie 2.03. QT 4.1.2<br> <br><br><br>